Need testers
Published on September 29, 2007 By thomassen In OS Customization
My screensaver Running Matrix WWW Link has an issue under Vista where the settings set in Control Panel isn't applied to the screensaver when it's running.

I used .NET's Properties.Settings to store the settings, but for some reason it didn't work well on Vista. I tried MSDN to find out what it could be, but with no luck.

So I ended up having to reinvent the wheel and write custom code to store the settings on Vista systems.

The beta is here: WWW Link

However, when I tried it on my main system, the thumbnail preview didn't work in the Control Panel.
It did however work on my second Vista system. And it also worked on my laptop running XP. Why it didn't work on my main system is a mystery as I didn't touch the code for the preview.

So I'm asking that a few people try the new beta and post back their experience.

Try it and answer there questions:

1. Your system specs:
CPU
Graphics card
RAM
OS
.NET version
Number of monitors
WB or any similar applications installed?

2. Did it run? If it didn't, did you get any errors?
2a. Did the old version work?

3. Did the little thumbnail preview in control panel work?

4. Did the settings work when the screensaver is started by Windows? (Just clicking the Preview button in Control Panel doesn't count.)

5. If you're running Vista, do you have UAC on? The screensaver on Vista stores the settings in an xml file where the screensaver is located. Which means in the System32 folder, I'm wondering if that might make the UAC to kick in. I've not got around to test it yet. I might move it to the application settings folder instead.


I've just started looking into making the screensaver use hardware accelerated DirectX. But that's for a much later version 2. I got other projects queuing up before that.
Comments
on Oct 02, 2007
Anyone?
on Oct 02, 2007
OK . . i'm in.
on Oct 02, 2007
just tested yet

CPU = Pentium 4 2.53Ghz
Graphics card= ATI GIGABYTE RADEON 9200
RAM= 768Mo
OS= WIN XP PRO SP2
.NET version = 3.0
Number of monitors= 1
WB or any similar applications installed?= Yes WB6

the thumbnail preview didn't work in the Control Panel = work here

if the text is not green but red it's good

the only thing is that the screen come a little "jumpy" but maybe the graphic card or the monitor itself (i'll have really soon to buy a new one)
on Oct 02, 2007
1. Your system specs:
CPU
Graphics card
RAM
OS
.NET version
Number of monitors
WB or any similar applications installed?



2. Did it run? If it didn't, did you get any errors?
2a. Did the old version work?

3. Did the little thumbnail preview in control panel work?

4. Did the settings work when the screensaver is started by Windows? (Just clicking the Preview button in Control Panel doesn't count.)

5. If you're running Vista, do you have UAC on? The screensaver on Vista stores the settings in an xml file where the screensaver is located. Which means in the System32 folder, I'm wondering if that might make the UAC to kick in. I've not got around to test it yet. I might move it to the application settings folder instead.


1.



Component Details Subscore Base score
Processor Intel(R) Pentium(R) 4 CPU 2.80GHz 4.1
4.1
  Determined by lowest subscore
Memory (RAM) 2.00 GB 4.1
Graphics Radeon X1650 Series 4.4
Gaming graphics 799 MB Total available graphics memory 4.8
Primary hard disk 47GB Free (77GB Total) 5.2
Windows Vista (TM) Business

System  
  Manufacturer INTELR
  Model Cyberpower Computer
  Total amount of system memory 2.00 GB RAM
  System type 32-bit operating system
  Number of processor cores 1
  64-bit capable No
Storage  
  Total size of hard disk(s) 263 GB
  Disk partition (C:) 47 GB Free (77 GB Total)
  Disk partition (D:) 137 GB Free (186 GB Total)
Graphics  
  Display adapter type Radeon X1650 Series
  Total available graphics memory 799 MB
        Dedicated graphics memory 512 MB
        Dedicated system memory 0 MB
        Shared system memory 287 MB
  Display adapter driver version 8.380.0.0
  Primary monitor resolution 1280x1024
  DirectX version DirectX 9.0 or better
All the ODNT suite that runs on Vista

2. It ran.  No errors.
2a. never had previous version
3. Yes, even picked up my config
4. Yes
5. UAC off via TweakVista

I'll see about testing in XP later.
on Oct 02, 2007
the only thing is that the screen come a little "jumpy" but maybe the graphic card or the monitor itself (i'll have really soon to buy a new one)

It's quite CPU intensive. Turning of the headers will help.
I'm hoping a DirectX version will be a big improvement if I can manage to work out how to make use of hardware acceleration in C#. But that's for the future!

Thanks for the feedbacks. So far so good.
How ironical that it doesn't work properly on my own main system...
on Jul 24, 2008
Sorry for posting in an old thread... but I tried this and got an error when changing the settings. Here are the details (I can't make heads or tails out of them, but I thought they might be useful). I'm on Vista 64bit with UAC enabled. Settings work in preview but not when I run the .scr file or if Windows runs it (it goes back to default, same as the original version).

CPU: Q6600
Graphics card: 8800 GT
RAM: 4GB Corsair (cheap kind, can't remember exactly which)
OS: Windows Vista Premium 64 bit
.NET version: No idea
Number of monitors: One, running at 1680x1050
WB or any similar applications installed?: I assume you mean WindowBlinds. I have AVG 8.0, LogonStudio Vista (trial), ObjectDock (trial), TweakVista (trial), and a few Nvidia/Logitech apps.

And the error message (details):
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.UnauthorizedAccessException: Access to the path 'C:\Windows\system32\RunningMatrix.xml' is denied.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode)
at RunningMatrix.xmlSettings.save()
at RunningMatrix.frmOptions.btnOK_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
Running Matrix
Assembly Version: 1.1.1.0
Win32 Version: 1.1.1.0
CodeBase: file:///C:/Windows/system32/Running%20Matrix.scr
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
gtg56pcb
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:





When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


EDIT: Just tried with UAC off: it WORKS with my custom settings! Is there a way to have this particular file to bypass UAC? 'Cause I'd hate to leave it off...
on Jul 29, 2008
Ah, I'd never tested it with 64bit system, nor UAC on. I have a suspicion that 32bit users will get that error as well. I think it's because Vista wants applications to write in the user folder instead of the program files folder or the system folder.

After I finished my studies and began full time job in the real world I've had less and less time to work on stuff like this. Hence why the latest version is a beta which hasn't been updated for a while.

I will try to allocate some time to have another go with this project. At least this issue as I think it'd be a simple matter of changing where the settings are saved.
on Jul 29, 2008
Meanwhile, you can edit the RunningMatrix.xml file yourself.

The opacity value goes from 0.0 to 1.0. So 50% opacity would be represented by 0.5.

I can't remember the format the colour green is in. But from the xml file on my computer when I set it to Green (RGB 0,255,0) it is -8323328.
Meta
Views
» 1215
Comments
» 8
Category
Sponsored Links